HAFNIUM/Exchange Server Attacks

HAFNIUM/Exchange Server attacks: Clients who may be worried about their Exchange email because of these attacks – as per Microsoft’s advice, those using Office 365 are already patched and not affected by these known attacks. Only clients running Exchange on their own servers need to ensure they are patched to date; our clients running these servers are already patched. If you’re unsure whether your current version of Windows includes these updates or not – please do contact us to get more information on how we can help keep our clients safe from cyber-attacks!

 

Web Design and Optimisation by SEO Manchester Ltd | Sitemap